Faulty SD-card reader Gladius Mini S, replaced several times


New member

I have had the Mini S for about a year and a half soon, and I have yet to be able to use it normally.

The SD-card reader is seemingly taking in water, and breaks almost as soon as it goes in the water. Sometimes it crashes the app, and my phone restarts, sometimes it just hangs on record with a spinning animation not being able to stop the recording, sometimes it gives an error message saying timeout, etc. forcing me to restart it, and once it is back up and running, the SD card is gone, and it shows the internal 13.2 GB available memory. One time it was completely out of control and fighting my inputs, rolling over, both with USB and wireless. So I have lost some recordings, one of about 30 minutes in length, and other shorter videos, and have not been able to use it normally when out on expeditions.

On my last dive, the depth sensor got stuck on 13.5m and Pitch just showed 0.
I recorded some footage on the internal memory, but once i played it back, it has terrible ghosting and smearing, and there is a pulsating effect every second when the image "updates or clears" itself. I did use it with default settings, so 4K 30, with 20Mbs bitrate, so I'm not sure if the bitrate is to blame or maybe EIS or another setting, or if it was caused by the SD card reader. I could not notice it while recording on my phone, only when playing it back later at home. Apparently is should have been closer to 45? I've always just set it to 60 previously, but did not change any settings for my last trip, with the "new" unit.

The SD-card reader has been replaced probably 5-6 times, Chasing has also produced different models of it, with 1 and 2 o-rings, I've used teflon tape, the last time the ROV apparently got replaced by a different working and tested unit, which also gave the timeout and crashed my app and phone. As far as the workshop and I have been able to figure out, the water comes in along the wire or someplace else forcing its way up through the reader and into the cap, and not over the treads and o-ring into cap.

So i was just curious if anyone knows of others with similar issues or have experienced it themselves?

Usually the controls, the claw, and recording to the internal memory works fine. The cable for the claw has also been replaced with a longer one, after i complained about it being to short, causing unnecessary pressure on the connections, causing a little leakage. I've also has water come into the main tether point, causing some white "corrosion" from the salt. It was corrected with some grease, and seems to be better on all the tether connections now, but I have also had to use a wrench to get a tighter seal, than what i achieved by hand, like the instruction video shows.

I'll add the link to my onedrive file with screenshot and video from my last trip that i've also shared with the workshop. https://1drv.ms/u/s!AtNoF7OyNwYFjNIVSfrVZplmDEu6iQ?e=qXhqfp

Any input is appreciated =)

Best regards


New member
After recieving a unit from the replacement program that supposedly was tested and working, and turned out to be equippped with an old part that immediately died once it got sent out into the sea, I recieved a brand new unit from the importer of Chasing products, and so far it has worked without fail. I tested it twice, down to about 15 meters for about an hour or more, and then later down to 30-40 meters for the remaining battery life, and there was no issues with water shorting the sd card reader.

So hopefully Chasing as solved the issue, and all new units and replacement parts will be up to standard. Can it do 100 meters as advertised? Hard to say, not sure i'm willing to test it^^.